Nexus Bytes System Heart Beat - Nyc power outage – Incident details

All systems operational

Ever wondered if we are alive? Come check out our heartbeat!

Nyc power outage

Resolved
Operational
Started almost 3 years agoLasted 13 days

Affected

NYC

Operational from 6:51 PM to 3:01 AM

Updates
  • Resolved
    Resolved

    We just resolved the issue!

  • Monitoring
    Monitoring

    We implemented a fix and currently monitoring the result.

  • Investigating
    Investigating

    We are currently investigating this incident.